Thursday, June 9, 2011

Cisco, HP, and Extreme Network's Equvilent Commands

My colleague and I have evaluated HP Procurve and Extreme Summit switches a while ago. Here are some of the Cisco equivilent commands:

Time

Cisco:
clock timezone pst -8
clock summer-time pst recurring
ntp server 10.0.0.10


HP:
timesync sntp
sntp unicast
sntp server 10.0.0.10 10.0.0.11
time timezone -480 daylight-time-rule continental-us-and-canada


Extreme:
Config sntp-client primary 10.0.0.10
Config sntp-client update-interval 3600
Config timezone name PST -8 auto




ACCOUNT 


Cisco:
username tester privilege 15 password 0 password
service password-encryption


HP:

Password manager user-name tester1 plain xxxxxx
Password operator  user-name tester2 plain xxxxxx

Extreme:
Create account admin tester xxxxxx

Hostname

Cisco:
 hostname xxx-xxx

HP:
 hostname xxx-xxx

Extreme:
config snmp sysname xxx-xxx

Logging

Cisco:
 logging snmp-authfail
logging console informational
logging monitor informational
logging 10.10.10.10
logging 10.10.10.11

 
HP:

Logging system-module console
Logging 10.10.10.10
Logging 10.10.10.11
Logging severity error
Logging severity major

Extreme:



TACACS/Radius

Cisco:
aaa new-model
aaa authentication login default group tacacs+ local
aaa authorization exec default group tacacs+ local
aaa authorization commands 1 default group tacacs+ none
aaa authorization commands 15 default group tacacs+ none
aaa accounting exec default start-stop group tacacs+
aaa accounting commands 1 default start-stop group tacacs+
aaa accounting commands 15 default start-stop group tacacs+
!
aaa session-id common


tacacs-server host 10.10.10.20
tacacs-server host 10.10.10.21
tacacs-server directed-request
tacacs-server key 7 1212121212121212
radius-server source-ports 1645-1646

HP:



aaa authentication login privilege-mode
aaa authentication console login tacacs local
aaa authentication console enable tacacs local
aaa authentication telnet login tacacs local
aaa authentication telnet enable tacacs local
aaa authentication ssh login tacacs local
aaa authentication ssh enable tacacs local

Radius Support (no accounting, local user authentication)
aaa authentication login privilege-mode
aaa authentication console login radius local
aaa authentication console enable radius local
aaa authentication telnet login radius local
aaa authentication telnet enable radius local
aaa authentication ssh login radius local
aaa authentication ssh enable radius local


Extreme:
configure tacacs primary server 10.10.10.10 client-ip 10.38.1.1 vr VR-Default
configure tacacs primary shared-secret encrypted "aezie"
configure tacacs-accounting primary server 10.10.10.10 client-ip 10.38.1.1 vr VR-Default
configure tacacs-accounting primary shared-secret encrypted "aezie"
enable tacacs
enable tacacs-accounting
enable tacacs-authorization
create account admin neteng encrypted "0E98ig$FXDFGDLFEPM0iaVo/"
Enable tacacs
Enable tacacs-accounting
Enable tacacs-authorization


Config tacacs primary server 10.10.10.10 client-ip 10.38.1.1 vr vr-default

config tacacs primary shared-secret cisco

config tacacs-accounting 
primary server 10.10.10.10 cli
ent-ip 10.38.1.1 vr "VR-Default"

config tacacs-accounting primary shared-secret cisco
Config tacacs secondary server 10.10.10.20 client-ip 10.38.1.1 vr vr-default



Routing (OSPF) 

Cisco:
ip routing
router ospf 101
router-id 10.23.1.1
 log-adjacency-changes
 network 10.0.4.0 0.0.0.255 area 0.0.0.0
 network 10.0.5.0 0.0.0.255 area 0.0.0.0
 network 10.23.1.0 0.0.0.255 area 10.23.0.0
 network 10.23.100.0 0.0.3.255 area 10.23.0.0
 network 10.23.108.0 0.0.3.255 area 10.23.0.0
  
HP:
Ip routing
Router ospf area backbone range 10.0.4.0/24
Router ospf area backbone range 10.0.5.0/24
Router ospf area 10.23.0.0 range 10.23.1.0/22
Router ospf area 10.23.0.0 range 10.23.100.0/22
Router ospf area 10.23.0.0 range 10.23.108.0/22


Extreme:
Enable ipforwarding vlan backbone1
Enable ipforwarding vlan backbone2
Enable ipforwarding vlan workstation
Enable ipforwarding vlan voip
Enable ipforwarding vlan netmgmt

Create ospf area 0.0.0.0
Create ospf area 10.23.0.0
Config ospf add vlan backbone1 area 0.0.0.0
Config ospf add vlan backbone2 area 0.0.0.0


Config ospf add vlan workstation area 10.23.0.0


Config ospf add vlan netmgnt area 10.38.0.0
Config ospf add vlan voip area 10.38.0.0
Enable ospf



Domain Name 

Cisco:
ip domain-name it.bsd405.org
ip name-server 10.20.20.20
ip name-server 10.20.20.21
HP:
Ip dns domain-name it.bsd405.org
Ip dns server-address priority 1 10.20.20.20
Ip dns server-address priority 2 10.20.20.21
Extreme:


Crypto

Cisco:
crypto pki trustpoint MYORG
 enrollment retry count 3
 enrollment retry period 5
 enrollment mode ra
 fqdn xxx-co-agg-sw1.my.org


HP:
Ip ssh public-key manager XXXXXXXXXXXXXXXXXXXXXXXXXXXX

Extreme:
Config ssh2 key


Multicast

Cisco:
 ip multicast-routing

HP:
Ip multicast-routing
router pim
   bsr-candidate priority 10
   rp-candidate
   rp-candidate source-ip-vlan 232
   rp-candidate group-prefix 224.0.0.0 240.0.0.0
   rp-candidate hold-time 150
   exit

Extreme:
enable ipmcforwarding vlan "BackBone1"
enable ipmcforwarding vlan "Netmgmt"
enable ipmcforwarding vlan "VOIP"
enable ipmcforwarding vlan "Workstation"
enable pim snooping vr VR-Default

Config pim add vlan workstation sparse
Config pim add vlan voip sparse
Config pim add vlan backbone1 sparse

Config igmp snooping vlan workstation ports 1-x
Config igmp snooping vlan voip ports 2-y



SPT

Cisco:
spanning-tree mode rapid-pvst
spanning-tree extend system-id
spanning-tree vlan 1,230-232,238 priority 24576


HP:
Spanning-tree
Spanning-tree instance 1 vlan 1-999
Spanning-tree 1-46 admin-edge-port

Extreme:


Interface

Cisco:
interface GigabitEthernet1/0/1
 description : XXXXXX
 no switchport
 ip address 10.0.4.123 255.255.255.0
 ip pim sparse-dense-mode
delay 100000

Interface fa0/1-48
Switchport mode access
Switchport access vlan 23
Switchport voice vlan 28
Spanning-tree portfast

HP:

Int 47 name “XXXXXXXX”
Ip address 10.0.4.123/24
Ip pim sparse
Vlan 232 name “10.23.100.0/22_Workstation”
Untagged 1-46
Tagged 47-48
Exit

Extreme:



Trunk/Tagged Port

Cisco:
interface GigabitEthernet1/0/3
 description : XXXXXXXX
 switchport trunk encapsulation dot1q
 switchport mode trunk


HP:

The tagged command above will put the interface as “trunk port”

Extreme:



VLAN

Cisco:
interface Vlan232
 description : Data
 ip address 10.23.100.1 255.255.252.0
 ip helper-address 10.10.10.30
 ip helper-address 10.10.20.30

HP:

interface Vlan232 name “Data”
 ip address 10.23.100.1 255.255.252.0
 Ip helper-address 10.10.10.30
Ip helper-address 10.10.20.30



Extreme:
configure vlan default delete ports 1-26
create vlan "BackBone1"
configure vlan BackBone1 tag 914
create vlan "Data"
configure vlan Workstation tag 232
configure ports 25 auto off speed 10000 duplex full
configure ports 26 auto off speed 10000 duplex full
configure vlan BackBone1 add ports 1, 24 untagged
configure vlan Data add ports 23 tagged
configure vlan Workstation add ports 10-20 untagged

configure vlan Data ipaddress 10.23.100.1 255.255.252.0
enable ipforwarding vlan Data
configure vlan BackBone1 ipaddress 10.0.4.138 255.255.255.0
enable ipforwarding vlan BackBone1



2 comments:

  1. wheres the similar command like "ip helper" in extreme ????????

    ReplyDelete
  2. Thank you. It is very informative. Could you please post like this comparison command for LLDP, QoS, Access Port, Daisy Chain configuration etc some more also please.

    Thank you very much for your responses, any help or attempt to help will be appreciated :-)

    ReplyDelete